OpenSSL bugs: zero impact on Endian server appliances


As you may be aware, OpenSSL has recently experienced some security vulnerabilities. “Heartbleed” (CVE-2014-0160) is the most serious one so far, but minor ones, such as “Cupid” and CVE-2014-0224, have come up.

The good news is that none of the Endian UTM product family (hardware, software and virtual), including Endian Network, are exposed to the discovered vulnerabilities.

Trust Endian and choose our VPN server side solutions to keep your systems protected and enjoy a highly scalable, very quick and stable VPN service.

Your Endian Team